Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Advance wars save game, anyone test it ?
#1
Hi there,

I would like to know if someone tested Advance Wars, or Advace Wars 2, with the GBA emulator from Libretro include in the retropie kit from Ed.

"Instant saving", using hotkey+L or R shoulder work fine, but "in-game" saving won't.

For this game it's a big issue, and it's one of my favorite game, and my goal when i start to build my GPA kit.

Can anyone confirm that in-game save for this rom is not working properly ?
Reply
#2
Here's something I might try if I were you.
From https://ezflash.sosuke.com/viewtopic.php?t=3165#top
Quote:1. download gbata
2. run gbata
3. find the tab named "SRAM Patcher" , click on it.
4. towards the top of the program where it says "file name", click on the "..." button to browse for your unpatched rom.
5. under the "Save as" output alter the path to your preferred directory.
6. click patch

Almost your same question with a simple (maybe useless) reply:
https://retropie.org.uk/forum/topic/1734...n-t-save/2

I'm not sure this is related to your issue, but it's interesting:
https://retropie.org.uk/forum/topic/509/...a-emulator

Another interesting search result that's somewhat related to this topic:
"War Room Challenge 2012 - Advance Wars 2
Hack of Advance Wars 2: Black Hole Rising"
http://www.romhacking.net/hacks/909/
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
Thanks a lot for your help. This week-end i patch my Roms and it work just fine now.

By the way it's necessary to perform a clean exit (hotkey + B) to return to the main retropie menu to "validate" the save. If you don't, and just power off , with a long press on power button, save is not available.
Same issue with zelda "link to the past" for exemple.

Is it a standard behaviour, or do i miss something ?
Reply
#4
(03-07-2017, 12:53 AM)sixbras Wrote: Thanks a lot for your help. This week-end i patch my Roms and it work just fine now.

By the way it's necessary to perform a clean exit (hotkey + B) to return to the main retropie menu to "validate" the save. If you don't, and just power off , with a long press on power button, save is not available.
Same issue with zelda "link to the past" for exemple.

Is it a standard behaviour, or do i miss something ?

Well, one "problem" with RetroPie is that nothing is quite "standard behavior" because it is a collection of emulators. Most were written by different people, so there is not quite a standard for this type of thing.

What is likely happening is that the emulator caches your save. It doesn't actually close/write the file until shutdown. I think you would find that some emulators do write immediately, but I can't say for sure.

Yes, I would just recommend that you exit the emulator before shutting down the GPA. In fact, if you made it a habit to use the software shutdown option, that might help you to always exit the emulator first.
Code:
[Main Menu -> Start Button -> Quit -> Shutdown System]
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)