Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
es_systems.cfg editing problem & Attract Mode Compile, kills ES
#1
Not sure why, but every time i try to edit this file, emulationstation breaks. Is there something in the software that will not allow me to edit this file? I do know what i am doing, i have been editing this file to add more "systems" for years now. Also, i compiled attract mode, and it works on the GPA, but it kills Emulationstation, i get an error that "emulationstation" is an illegal instruction message, however...if i take the card and put it in my pi, that is hooked to my tv...ES boots up no problem. Any ideas? I have attract mode running really smooth, but it kills ES in the process. 

Thanks for any advice,

Freddy
Reply
#2
Yeah, I do have one idea. The error you describe is what would typically happen if you compile something for a Pi 3 and then run it on a Pi 0/1.

Did you compile on the Zero or on another Pi?
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
(09-12-2017, 05:38 AM)Flavor Wrote: Yeah, I do have one idea.   The error you describe is what would typically happen if you compile something for a Pi 3  and then run it on  a Pi 0/1.

Did you compile on the Zero or on another Pi?

yes i compiled on a pi3. i cant get it to compile on the zero. but, i have done this before using a regular retropie zero w image, to run attract mode on another pi zero. I have a pi zero running attract, just not in the GPA, and yes i did compile attact onto the GPA image using a pi3 and am getting those errors. Thank you for the reply. i will try to work around it. Any suggestions?
Reply
#4
(09-12-2017, 06:28 AM)mxstar1 Wrote:
(09-12-2017, 05:38 AM)Flavor Wrote: Yeah, I do have one idea.   The error you describe is what would typically happen if you compile something for a Pi 3  and then run it on  a Pi 0/1.

Did you compile on the Zero or on another Pi?

yes i compiled on a pi3. i cant get it to compile on the zero. but, i have done this before using a regular retropie zero w image, to run attract mode on another pi zero. I have a pi zero running attract, just not in the GPA, and yes i did compile attact onto the GPA image using a pi3 and am getting those errors. Thank you for the reply. i will try to work around it. Any suggestions?

There should be a compile option to target the Pi0/1 vs. the Pi2/3.  
I found this (if you're actually editing compiler options).
https://www.raspberrypi.org/forums/viewt...9#p1066416

You definitely can compile on the the Pi3 and target the Pi0/1/2/3.  I don't know if that forum post I linked to is the best for that or not.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)