Freeplaytech Forum

Full Version: R trigger button not working.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, so I finally got a chance to sit down and assemble and load up some games via a wifi dongle and my right trigger doesn't work. Its not an issue of clearance with trigger buttons as it doesn't work with the shell off, the tactile button it self is not working. It clicks, but no response. Neither in the retropie menu or the various snes emulators.

Am I overlooking something, is this a software issue or is this thing just borked?
We test each board before we send it, and one of the things we test is every button. That doesn't mean the button couldn't have died, but I think that's a lot probability guess at this point.

"So, what are high probability guesses?" you may ask.

I definitely would guess the shoulder plastic if you hadn't mentioned that it has the same problem with or without that. I have even seen them click and not work when the plastic is impeding the motion. It's like click, then move a tiny bit more, then make contact.

The other high probability guess is the solder joint (or pin header connection) between the Pi and the GPA board. I have seen some people's photos that I can tell have poor solder connections. Usually they are good enough, but you never know.

Do you have a multimeter that you could use to test the connection? We could determine if there is a problem between the button and the Pi or if the button itself is bad.