Freeplaytech Forum

Full Version: Potentially shorted battery circuit, please help.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Well I've just put the final touches on my Game Pie Advance, and I'm afraid I must've shorted something to do with the battery.

I ended up buying some flat back batteries that came with a charger.
(1200mAh Li-po Battery for Syma X5SW X5SC RC Quadcopter S1P5)
I charged em up and plugged one into the board, and things ran well.

So I did my final case modifications and installed the board, screen, etc. into the enclosure. But now when I try to plug in a charged battery, but the darn thing won't turn on. When I hold the power switch the screen flickers, but nothing more.

However I am still able to easily power and use the Game Pi Advance to play games if I plug it in to usb power via one of the 2 usb ports built right into the pi.

I am starting to wonder if I may have badly shorted something to do with the battery.

There is a bulge in the square black integrated circuit just above the power connections I soldered for the battery. I wonder if maybe when I was tinkering I accidentally shorted something.

I'm not sure how to troubleshoot this one. Any suggestions?
Can you describe how you plugged in the battery?
(02-26-2017, 02:45 PM)Flavor Wrote: [ -> ]Can you describe how you plugged in the battery?

I attached a photo showing the battery plugged in.

(I added the pins for a second battery pack, but I haven't tried 2 batteries yet.)

But since I found the bulge on the circuit my theory is I must've arced the red & black pins with my screwdriver or pliers when the battery was plugged in.
I asked about the battery, because the electrical engineer looked at your photo and thought that the battery was likely plugged in backward.

Another cause is if you had the battery shorted (as you mentioned) and then tried charging it.

To anyone else that comes along to read through this, be sure to trim any excess off the "bottom" side of H2 and H3 (the red connectors shown in the photos).

@metaColin, I will email you direct to figure out a way to get this fixed.