Freeplaytech Forum

Full Version: I Need Help With This Error!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hey Yall, So Anyways I Just Tried To Compile My Program And It Gives Me A Error Of A Unresolved Printf Symbol. So Can You Help Me Please!
You need to be more precise on your issue if you want some help
missing lib in your makefile?
You can attach a simple source file where the problem occurs so we can help.
(07-11-2021, 05:32 AM)sodthor Wrote: [ -> ]missing lib in your makefile?
You can attach a simple source file where the problem occurs so we can help.

[attachment=1305]

here is the file linked it is just a hello world program.
My bad, printf is not available on ngpc: there is no console where to display the text.
The function prototype is available in stdio.h but with a comment: Reserve
Maybe it was available with the dev unit / hw emulator, connected to a PC.
To display a string on the screen, I suggest you to use the library done by Ivan Mackintosh (PrintString) used in most homebrews (libray.c/.h)
[attachment=1306][attachment=1307]
Update: Now when I compile the code to a rom file for the emulator, It Gives me a error. The error says: SWI 7 is not valid or something like that, so can you guys help me please!
(12-29-2021, 08:37 AM)NeoGeoFreak2004 Wrote: [ -> ]Update: Now when I compile the code to a rom file for the emulator, It Gives me a error. The error says: SWI 7 is not valid  or something like that, so can you guys help me please!

Will you be able to show the complete error here?
Here is the error, so when I try to type in compile.bat into the command prompt, it compiles, but the emulator will not work with the ROM and pops up with an error message. This is the full error: [PC 100003] swi 7 not found. my code is compiling but crashing on the emulator. so that is the error message I am getting
(12-29-2021, 11:18 PM)NeoGeoFreak2004 Wrote: [ -> ]Here is the error, so when I try to type in compile.bat into the command prompt, it compiles, but the emulator will not work with the ROM and pops up with an error message. This is the full error: [PC 100003] swi 7 not found. my code is compiling but crashing on the emulator. so that is the error message I am getting

What emulator and what OS are you using? Did you try to open the rom direclty in the emulator?
I am using Windows 11 as my os and the emulator is neopop and also i did not try to launch the rom directly into the emulator.
Pages: 1 2 3