Freeplaytech Forum
Emulator issues - Printable Version

+- Freeplaytech Forum (
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Software (
+--- Thread: Emulator issues (/showthread.php?tid=4527)

Pages: 1 2

Emulator issues - sideshow801 - 01-18-2018

I am having issues with the following emulators:

Amstrad CPC - Will not show that roms were installed (doesn't show up on main menu)

Fire box arcade CPS1 - half of the games boot back to the menu

Fire box arcade CPS2 - all games boot back to the menu

Famicom disk system - all games boot back to the menu

Nintendo 64 - button inputs do not work

Neo-Geo - all games boot back to the menu

Does anyone have fixes for any of these?
Most of these work just fine on my raspberry pi 3

RE: Emulator issues - Flavor - 01-19-2018

Whenever you say "all games boot back to the menu," my first thought is that you are missing a BIOS file (or that you have the wrong one). This can be tricky and not necessarily obvious. For example, the Neo Geo page ( tells you to put the BIOS file with your game files. Other emulators want their BIOS file in the BIOS folder.

I will say that the arcade games are notoriously tricky to work with. Often they are based on MAME and you need to be quite sure that you have the proper MAME version of a game for the exact version of the emulator you're using.

If you are using the same game files as you do on your Raspberry Pi 3, then you would want to be sure that you are using the same emulator on both machines. When you choose a game, you can hit the A button (while it's starting) to get the runcommand menu. In there, you can choose which emulator to use. It could be that your RPi3 system is set to use a different emulator than the Freeplay CM3 is.

As for N64, see if you are using one of the emulators that starts with "lr-". That will mean that it's compiled for use with "LibRetro" and then it will take the inputs from RetroArch/EmulationStation. Otherwise, (like if you're using Mupen64plus, see it will need to have its own controls configured.

I think there's a lot of technical info at that can really help get N64 controls mapped in Mupen64plus, but it's fairly involved. I'd try using the "lr-" emulators first and see how that goes for you.

RE: Emulator issues - sideshow801 - 01-19-2018

I got my Wi-Pi module yesterday and was able to update my BIOS for everything and this fixed the problem that I was having with the N64 emulator. However, I seem to have a new issue. Ever since I updated everything, I can no longer hit the A button to get to the run command menu to switch settings and emulators. It just loads the game. This seems to be the case with all emulators now. I'm not sure what settings were changed with the new updates or if I accidently changed some settings somewhere along the way.

RE: Emulator issues - Flavor - 01-20-2018

In the main menu, select RetroPie. Then select "Runcommand Editor." In there you can enable or disable the launch menu.

RE: Emulator issues - sideshow801 - 01-20-2018

Launch menu (currently: Enabled)

This setting was never changed. I'm still not able to open the run command menu.

RE: Emulator issues - 99.1% Pure - 01-22-2018


I just received my kit CM3 and it's great but I also have no command available on N64 .... I tried what you explained ... update ... command editor. .. but nothing works ... can you help me ???? I play Mario Kart 64 !!! my life is laying on it!

Thank you !

RE: Emulator issues - Flavor - 01-22-2018

Apparently this is somewhat of a known issue. I will try to find some information on it.

That thread and some others I found it seemed to suggest that maybe upgrading versions can cause some issues. I may need to test this to see how it works for me, and then the next step might be for me to start with a fresh install of RetroPie and then add our mods to make it work on the Freeplay CM3.

RE: Emulator issues - 99.1% Pure - 01-22-2018

perfect !
thanks a lot !!!!

RE: Emulator issues - Flavor - 01-24-2018

After looking into this for a while, I now understand what happened.  Unfortunately, it's not the easiest thing to fix.

Actually, it's very easy if you can SSH into your system, but most users aren't used to that.

I actually don't know why you don't get the runcommand editor (the "Press A Button To Configure" prompt) when launching.  That is still a mystery.  It comes up on mine.

But, I do know why the button inputs aren't working, and I have a fix for that.

I will release a new SD image soon.

If you can SSH into your machine, here is the fix.

cd /opt/retropie/configs/n64
mv InputAutoCfg.ini InputAutoCfg.ini.bak

Then, in the main EmulationStation/RetroPie menu, hit the START button.  Select CONFIGURE INPUT.
In there, hold the A button down until you start configuring the "GPIO Controller 1".
Go through all the Up, Down, Left, Right, etc.  To skip a button that you can't configure, hold down the A button.
When you get to the HOTKEY button (the last option), double-tap the power button (like ON->OFF-ON).

All you are doing is causing the system to regenerate the N64 button config file.

RE: Emulator issues - 99.1% Pure - 01-26-2018

I did exactly what you described is the result is the same : no button works !
For information the new generated file InputAutoCfg.ini is 0ko ...

Highly your new SD image!