Freeplaytech Forum
CM3 Troubles - No green light - Printable Version

+- Freeplaytech Forum (https://forum.freeplaytech.com)
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (https://forum.freeplaytech.com/forumdisplay.php?fid=24)
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Hardware (https://forum.freeplaytech.com/forumdisplay.php?fid=25)
+--- Thread: CM3 Troubles - No green light (/showthread.php?tid=4611)



CM3 Troubles - No green light - TravisChen - 04-30-2018

Hi there! First, want to thank you for the wonderful build instructions & forum. Really made the build process easy on the CM3. 

I am unfortunately having a problem. When I try to turn on the CM3 I get the infamous just white screen. Holding the power down for >10 I also don't get the green light. Seems like most people who have this issue have a green power light indicating a screen problem but I don't. Which leads me to think it's the SD / image or something wrong with the CM3 itself. I have tried a lot of things here:
  • I am using the img linked to from the build guide. Note, I do see the boot drive when I insert into my comp with content (e.g. config.txt)
  • I've even tried old versions of the img (in the archive folder)
  • Tried unzipping before burning
  • On mac - tried both Apple Pi Baker and Etcher
  • Tried multiple SD cards (one 128 gb, one 8 gb)
  • Tried re-seating the CM3
Any thoughts? Would really appreciate any suggestions! Only thing I can think of next step is to try to use a PC to create the SD. Or try a third SD card. 

Pre-thanks for the help!


RE: CM3 Troubles - No green light - Flavor - 04-30-2018

Do you have HDMI to hook up to? That can help.

Are you sure that the SD is clicking into place?

Did you do anything with the Compute Module itself? Could it be unseated?


RE: CM3 Troubles - No green light - TravisChen - 04-30-2018

I figured it out. Took out the Pi and noticed that adapter had two of its pins with a small piece of solder connecting them. Took a very sharp blade and ran it between the two pins to disconnect them. Booted up and all works!


RE: CM3 Troubles - No green light - Flavor - 04-30-2018

Awesome! Thanks for the update, Travis!