Freeplaytech Forum
Post-Build Setup & Tuning - Printable Version

+- Freeplaytech Forum (
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Software (
+--- Thread: Post-Build Setup & Tuning (/showthread.php?tid=4652)

Post-Build Setup & Tuning - jazzylean - 07-30-2018

Hey Everyone,

I wanted to start a thread here to discuss a topic I haven't found too much info on; setting up your Freeplay after you've built it.  

I have a few specific questions on what to do with my Freeplay CM3 now that I've finished building, but wanted to create this thread for others to ask questions about setting up their Freeplay's as well.

The main issue I've been having has been adding ROMS to my freeplay.  When I boot my freeplay, I get the retropie configuration screen and access to the menus.  I've followed the guide for formating a USB drive, adding a 'retropie' folder, plugging it into my freeplay to get the ROMS folder, copying ROMS to this folder, and plugging it back in my freeplay; but upon rebooting emulation station, I cannot find the systems or roms I added.  

Are there other steps I missed?  Is there additional setup I need to do on my Freeplay CM3 before I can add ROMS?  

Additionally, are there any other set up steps or settings to tune to get the most out of my Freeplay CM3?

Thanks in advance! I'm loving how supportive and helpful this community is!

RE: Post-Build Setup & Tuning - Flavor - 07-31-2018

I'm pretty surprised that the USB transfer method didn't go as planned. Can you tell us what game systems you added ROMs to? What format are the ROMs in? It's possible that you may have put them in the wrong place or added them in the wrong way. Some systems (like arcade games) are notoriously unclear as to which ROMs to use and how to get them in the correct format.

I think that most systems will accept ZIP files. Some may accept .gz or .7z. Some may not. Some systems may expect the ROM's file name to have a certain extension and won't accept others (that may be common).

If your system is on the network, you can use the SFTP method to install ROMs or to see what is currently on your system.

Check here to be sure you did the USB method properly and to see the SFTP method.

Let us know how that goes and let's get this thing up and running!

RE: Post-Build Setup & Tuning - Cleantex (Dragu) - 08-03-2018

In general all my retro devices have Wifi, the Pi3 anyway and for the CM3 I use an unpowered hub with an Edimax EW-7811 as proposed.
As on Recalbox and Retropie I am on the network router with all this, I have on local PC's Putty as terminal and for transfer of roms and other datas Filezilla. Putty and Filezilla is everything you need to control your devices. When something is to compile, I put a Raspian SD card in my bartop and use it for compiling, control it over Putty and pass the result directly over PC with Filezilla, you can have a few open connections at the same moment.

RE: Post-Build Setup & Tuning - fritoking - 08-19-2018

I am having these same issues. I am very unfamiliar with linux, and after 2 days have finally extracted the roms from an image i use on my raspberry pie 3. My issue is when i plug my usb drive (after formatting and adding the retropie folder of course) the cm3 does nothing with it. I am seriously about to pull my hair out. The drive works fine in my pie 3 as it adds the directories needed , just not on the cm3

RE: Post-Build Setup & Tuning - Flavor - 08-21-2018

Hey fritoking.

I wonder if your USB drive is trying to use too much power from the Freeplay CM3. Is it a flash drive or an actual hard drive? If you have a powered USB hub, you might want to try using that, so it can supply the power.

RE: Post-Build Setup & Tuning - fritoking - 08-21-2018

(08-21-2018, 03:24 AM)Flavor Wrote: Hey fritoking.  

I wonder if your USB drive is trying to use too much power from the Freeplay CM3.  Is it a flash drive or an actual hard drive?  If you have a powered USB hub, you might want to try using that, so it can supply the power.

Well, I finally got it to work somewhat. I had an unpowered hub , tried it and successfully added a bunch of roms.  My nephew played it for about 3 hours last night. Today I decided to try and add more roms with the same setup and no luck. So I tried writing a new image to a larger card and it wont add the retropie file system to the card. It's getting very frustrating to be quite honest. I do have a powered hub I can try.