Freeplaytech Forum
l2/r2 analog stick board - Printable Version

+- Freeplaytech Forum (https://forum.freeplaytech.com)
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (https://forum.freeplaytech.com/forumdisplay.php?fid=24)
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Hardware (https://forum.freeplaytech.com/forumdisplay.php?fid=25)
+--- Thread: l2/r2 analog stick board (/showthread.php?tid=4669)

Pages: 1 2 3 4 5 6 7


RE: l2/r2 analog stick board - Flavor - 09-20-2018

Is it only L/R that are backwards or is U/D also flipped?

During the Configure Input of RetroPie, did it work properly there? I mean, you define all the new controls and it asks you to press LEFT, and I assume you didn't press RIGHT, correct?

Also, where is it showing as backwards? In an emulator? If so, which emulator?


RE: l2/r2 analog stick board - NewAgeRetro - 09-20-2018

(09-20-2018, 08:39 AM)Flavor Wrote: Is it only L/R that are backwards or is U/D also flipped?

During the Configure Input of RetroPie, did it work properly there?  I mean, you define all the new controls and it asks you to press LEFT, and I assume you didn't press RIGHT, correct?

Also, where is it showing as backwards?  In an emulator?  If so, which emulator?

It is only the L/R that is flipped. U/D works perfectly. Yes it worked in setup. I just loaded Doom and controls were correct. I guess it’s only in the N64 emulator. I tried editing the mupen64plus.cfg file to say (0-,0+) instead of (0+,0-) but no luck. My search continue so to figure out how to invert that axis for n64. 

Thank you for the quick reply.


RE: l2/r2 analog stick board - Flavor - 09-20-2018

Maybe choose a different N64 emulator? I'm pretty sure it worked fine for me, but maybe it was with lr-mupen64plus. I would guess that the 'lr-' emulators do it properly (whatever you set it in RetroPie Config Input).
https://github.com/RetroPie/RetroPie-Setup/wiki/Nintendo-64


RE: l2/r2 analog stick board - maxh123 - 09-21-2018

(09-20-2018, 08:28 AM)NewAgeRetro Wrote: I got the L2R2 board all set up with a PSP-1000 joystick. The only problem is that left and right are backwards. I tried setting it up the correct way and backwards in the Configure Input screen and even tried to fix it by editing the RetroArch configs. Nothing seems to make it read correctly.

If anyone knows how to fix this it would be much appreciated.

I ran into the same issue on n64 games only. I edited the InputAutoCfg.ini and just swapped the + and - for axis 0. I also tweaked some other buttons to my liking, like making the d-pad the c-buttons. 

Other things like PSP worked just fine.


RE: l2/r2 analog stick board - NickM - 09-26-2018

I just finished installing the add on board. The fan works just as expected with the commands. My issue is that I used the commands for the the controls and everything loaded successfully yet I still get no input from L2/R2. What am I doing wrong here?!


RE: l2/r2 analog stick board - Flavor - 09-26-2018

Did you edit the conf file? See https://docs.google.com/document/d/1GkmF4kXyXvcFUH_lFjIykzFlOVgB8iRxvx1VnZ1wgEY/edit#heading=h.ujmw1qacovji for info about the analog edits, but you will also need to comment in/out a line for the extra digital inputs.

After that (and rebooting), run through the CONFIGURE INPUTS by hitting START in the main menu.


RE: l2/r2 analog stick board - NickM - 09-26-2018

(09-26-2018, 04:43 AM)Flavor Wrote: Did you edit the conf file?  See https://docs.google.com/document/d/1GkmF4kXyXvcFUH_lFjIykzFlOVgB8iRxvx1VnZ1wgEY/edit#heading=h.ujmw1qacovji for info about the analog edits, but you will also need to comment in/out a line for the extra digital inputs.

After that (and rebooting), run through the CONFIGURE INPUTS by hitting START in the main menu.

I’m not worried about the psp joystick quite yet. I’m unsure of what to modify here just to get l2/r2.


RE: l2/r2 analog stick board - Flavor - 09-26-2018

Your /etc/modprobe.d/mk_arcade_joystick.conf file should look something like this.


Code:
options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,-1,-1,-1,-1 hkmode=2
#this next line is for use with 4 extra buttons (maybe L2,R2,C,Z)
#options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,41,40 hkmode=2
#this next line is for use with a single PSP1000 analog stick
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41
#this next line is for use with 2 PSP1000 analog sticks
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 x2addr=75 y2addr=79 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41

Make it look like this, and then reboot and run the CONFIGURE INPUT.


Code:
#options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,-1,-1,-1,-1 hkmode=2
#this next line is for use with 4 extra buttons (maybe L2,R2,C,Z)
options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,41,40 hkmode=2
#this next line is for use with a single PSP1000 analog stick
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41
#this next line is for use with 2 PSP1000 analog sticks
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 x2addr=75 y2addr=79 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41



RE: l2/r2 analog stick board - NickM - 09-26-2018

(09-26-2018, 06:13 AM)Flavor Wrote: Your /etc/modprobe.d/mk_arcade_joystick.conf file should look something like this.


Code:
options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,-1,-1,-1,-1 hkmode=2
#this next line is for use with 4 extra buttons (maybe L2,R2,C,Z)
#options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,41,40 hkmode=2
#this next line is for use with a single PSP1000 analog stick
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41
#this next line is for use with 2 PSP1000 analog sticks
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 x2addr=75 y2addr=79 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41

Make it look like this, and then reboot and run the CONFIGURE INPUT.


Code:
#options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,-1,-1,-1,-1 hkmode=2
#this next line is for use with 4 extra buttons (maybe L2,R2,C,Z)
options mk_arcade_joystick_rpi map=4 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,41,40 hkmode=2
#this next line is for use with a single PSP1000 analog stick
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41
#this next line is for use with 2 PSP1000 analog sticks
#options mk_arcade_joystick_rpi map=4 hkmode=2 i2cbus=1 x1addr=72 y1addr=77 x2addr=75 y2addr=79 gpio=4,17,6,5,19,26,16,24,23,18,15,14,-20,42,43,-1,41

That was it! Thanks a lot.


RE: l2/r2 analog stick board - aarontrini85 - 10-06-2018

(09-05-2018, 01:47 PM)Flavor Wrote: It would be interesting to do a
uname -a
and then reboot and do
uname -a
a second time.  I'm wondering if it installed a new kernel that you aren't using.

OR, you got kernel headers for a kernel that you did not actually get yet.  If so, maybe running
sudo apt install raspberrypi-kernel
and then rebooting could help.

It seems as if there's some mismatch, anyway.

The command
uname -a
or
uname -r
should show the current running kernel version.

I'm guessing that it's 4.14.52-v7+, but the headers you got were 4.14.62-v7+.


You were right just tried my old image again and did the sudo apt install raspberrypi-kernel then went and ran the install again and it seems to be working good.  I still cant get my left and right inputs to be noticed on my analog stick but i think thats my horrible soldering more than anything else.


Thanks for the great support and sorry it took so long for me to actually get around to trying anything other than the new image.