Freeplaytech Forum
Red LED will not turn off - Printable Version

+- Freeplaytech Forum (
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Hardware (
+--- Thread: Red LED will not turn off (/showthread.php?tid=4676)

Red LED will not turn off - Dannymozzarella - 09-13-2018

Hi everyone,

I’m having a problem with my FPZ. I fell asleep playing it last night (I love this thing!) and apparently the battery died in the middle of the night. I woke up this morning and the red power led (on the front of the gba) was on and would not turn off. I was able to start the system and turn it off again, and the red led stayed on. Here is what else I’ve tried:

I fully charged the battery, the red led stayed on the entire time.
After fully charging, I started and shut down the system. 
I removed the battery and plugged it back in.
I removed the battery and turned the system on by powering it only through the charging port.

Some other info: I am currently using the double battery solution (but this has never been a problem before), and I have the backlight adjustment ribbon installed. I believe I have the second newest free play image installed, but I’d have to verify this. Retropie 4.3.

This light will not turn off! I haven’t opened the system, but it seems like the green led MIGHT also be on but may be drowned out by the shine of the red led (is that possible?).

Has any one else had this problem before? Any other ideas?


RE: Red LED will not turn off - Flavor - 09-13-2018

I don't think I've ever seen this before. Let me do some digging about what conditions might cause this to happen, and I'll try to get back to you.

Is the unit completely usable, and it just has the red LED on all the time? Yes, it's possible/likely that the green and red LEDs are both on.

RE: Red LED will not turn off - Flavor - 09-13-2018

In the meantime, can you try going through the battery troubleshooting steps at and posting the results? If there is anything else out of the ordinary, it could be a good clue. Thanks!

RE: Red LED will not turn off - Dannymozzarella - 09-13-2018

Hey there Flavor,

I tried everything on the battery troubleshooting page, no unexpected results at all. Everything functions 100% on the system otherwise, an the green led is coming on with power on. It’s very strange, as soon as the unit gets power the red led is on.

Thank you for the quick support!

RE: Red LED will not turn off - Flavor - 09-13-2018

Okay, Dannymozzarella. That's quite odd. I don't think we've ever heard of this happening before.

Could you try to remove all power cables and batteries. Without anything plugged in, push and hold the power button for 10 seconds. Then let it sit for 10+ minutes like that. Then plug in a microUSB cable. Does the screen go white and then off really quickly when you apply power? Does the red LED pop on when you plug it in? Does the red ever turn off?

Do you have the Freeplay Zero opened up by any chance? If so, could you post photos of the PCB?

Is there any chance that the solder points on the Raspberry Pi Zero could be bad? I know that it sounds weird, but could it just be a coincidence that it occurred when you fell asleep playing? There are a couple points that if they were bad or bridged, it could cause the red LED to be on.

RE: Red LED will not turn off - Dannymozzarella - 09-13-2018

I did as you said, and exactly what you said is what happened when I plugged in the microusb- quick screen flash of white, then the red led came on instantly. Never turned off.

I can open the case tomorrow and post some photos. I didn’t solder the pi, I used the hammer header. The only soldering I did were the 2 wires for the brightness adjuster to the back of the pcb. I can take some photos of that, but they didn’t give me any trouble and the brightness adjuster has been functioning fine.

I’ve played the system until the light has turned red before many times, but never to the point where it shut itself off. And every time I’ve recharged it after that the red light has turned off.

RE: Red LED will not turn off - Dannymozzarella - 09-13-2018

Here are the photos of the board.

One thing I did notice- I left the board completely disconnected from power overnight, then this morning I plugged in one battery and the LED did not come on. I unplugged it, then plugged in the microUSB on its own, then the red light flickered on then off once, then came on again. Now its on again indefinitely whenever any power is attached- battery or usb.

RE: Red LED will not turn off - Dannymozzarella - 09-14-2018

Forgot to mention- all this still happens with the pi disconnected from the board.

RE: Red LED will not turn off - Dannymozzarella - 09-14-2018

Thinking it was something with the dimming controller, I desoldered the points, removed the wires, cleaned the points and board and tried all the previous tests. Red led remains.

Re soldered the wires on, no change.

RE: Red LED will not turn off - Flavor - 09-14-2018

Hey Danny. I’m sorry that I missed your replies today. I would usually get an email notification, but I guess I didn’t.

I looked at your photos, and I didn’t see anything obviously wrong there. I think you have done a pretty good job of debugging everything, and I can’t come up with any reason it would be acting this way.

I think that we should open a support ticket, and then we might need to repair or replace some parts.

Could you go to and open a SUPPORT inquiry there. Please just copy and paste as much information from this thread as you think is useful. Then we can talk about the options for getting it fixed.