Freeplaytech Forum
Cm3 USB not working - Printable Version

+- Freeplaytech Forum (
+-- Forum: Freeplay Zero / Freeplay CM3 / Game Pie Advance (
+--- Forum: Freeplay Zero/CM3 (AKA GPA) Software (
+--- Thread: Cm3 USB not working (/showthread.php?tid=5042)

Cm3 USB not working - Hobby-Schrauber - 10-19-2019

Hi there,

i usefully build my Boxypixel cm3 but i have a problem to add roms via USB. I tried this guide
but when the usb stick is plugged in the cm3 it lights up for one second and than notthing happens. I tried two usb sticks but i have the same issue  Sad.

Please help  Exclamation

RE: Cm3 USB not working - Flavor - 10-19-2019

When you say, "nothing happens," what do you mean? Are the USB sticks formatted with FAT32? Did you create the folder named retropie in the root of the USB stick? Then, you popped it in on the CM3, right? It lit up and then you waited for a minute or so? When you pop it back into your PC, is there anything in the retropie folder?

RE: Cm3 USB not working - Hobby-Schrauber - 10-19-2019

Yes i formatted it in Fat32 created the folder. Than plugged the stick in the cm3 and nothing happens when i stick it back in the pc there are zero new folders.

Very frustrating Undecided. The sd image is the newest one. Is there anybody with the same issue what can i do?

RE: Cm3 USB not working - Flavor - 10-19-2019

Try doing this with the micro USB plugged in powering/charging the Freeplay CM3. I wonder if your USB stick could be pulling too much power or something like that.

What USB stick is it? Is it flash memory or an actual hard drive?

Do you happen to have a powered USB hub that you could try it with?

Have you used/tried any other USB devices (WiFi/Ethernet/controller/keyboard)? If you could, try one of those. I guess the keyboard may be the easiest to test. I just want to confirm that the USB port itself is functioning properly.

RE: Cm3 USB not working - Hobby-Schrauber - 10-19-2019

I tryed it with plugged in power cable its the same. I tryed three usb sticks it a scan disk extreme sd card with 128GB, a transcend ultra speed with 16GB an a 8GB no name stick all sticks are not working!!! I dont have a USB Hub and i dont know how can i test a keyboard this is soo Windows 95  Huh Huh Huh . I connected two keyboard no reaction, than i test the cm3 without the boxypixel housing the same thing the usb port is not working. I think i have a faulty usb port, what  should i do, i paid a lot of money for that  Angry

RE: Cm3 USB not working - Hobby-Schrauber - 10-19-2019

Now it worked after i reinstalled the cm3 modul  Dodgy

RE: Cm3 USB not working - Flavor - 10-22-2019

That's quite weird, but I'm very happy to hear that you got it working, now!

It must have been not fully seated before.

RE: Cm3 USB not working - Hobby-Schrauber - 10-22-2019

Thank you  Smile