Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WS Flash Masta v5.1
About Makaimura: I flashed the unpatched ROM to Slot 1 instead of the menu and so far it seems to work with sound and no sprite flickering. I also flashed a SRAM file filled with zeros, but I assume this is unrelated. Is it possible that the menu initializes the system wrong for Makaimura?

EDIT: RUN=DIM also works when started without menu from Slot 1.
nrq, this is very interesting news.

IIRC, I do not believe that the menu does anything at all to SRAM. It does do a small bit of "reinitializing" before jumping to another slot. I doubt that this is the culprit, but your information is really interesting. It indicates that I could be wrong on this thought.

Thank you for investigating this.
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )
Makaimura & RUN=DIM working is some pretty amazing news, will give that a shot, thanks @nrq :-)
now we need a patch Big Grin
Interesting Reddit thread:

Seems like even more games run when flashed without the menu. It also seems to fix the crash with GGP2 I reported earlier. Rhyme Rider Kerorican also should run properly, even One Piece Battle Colosseum apparently now runs.

I really hope we can get a patch for this!

I have been playing with my FlashMasta quite a bit.  It is a super fun little device. I tend to use it as a single rom device, the menu is pretty much useless since it only allows one save.

I do have one question though. "Tetris (J).wsc" is listed as working, and the rom does boot and run for me.  The only issue is that it doesn't seem capable of saving.  Whenever it tries to save the WS locks up completely.  Do I need an initialized save file or something first?
Strange, I've played plenty of Tetris on both a WSC & Crystal with the FM and it saves highscores etc. just fine. Always used the menu, though.
(10-27-2022, 06:27 AM)SirRockALot Wrote: Strange, I've played plenty of Tetris on both a WSC & Crystal with the FM and it saves highscores etc. just fine. Always used the menu, though.

That is really weird.  I have tried multiple times and I still get the issue.

Can you upload your save?  Maybe it is having trouble overwriting/initializing the save slot? I didn't see anyway to wipe saves to start from scratch.
Hm, I played many other games that save and Tetris was always able to overwrite the previous save. Do you have maybe an older cart revision with a save battery that's depleted or you're using the wrong ROM?

Congrats on releasing a new multi-save-slot menu! I currently can't try it, but this is exciting! Is it already known if this menu fixes the various incompatible games that before only ran when launched without the menu?

In the WS subreddit somebody already posted a bug report video, might be worth a look:

Forum Jump:

Users browsing this thread: 2 Guest(s)