Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to work with SD card partition?
#31
(11-05-2019, 06:20 AM)Happyhaha2000 Wrote:
(11-05-2019, 06:15 AM)Flavor Wrote: By the way, the screenshot I posted was with an Edimax adapter.  With the Edup, my lsusb (through a powered hub) looks just like yours for the WiFi adapter.  

What does your screen look like if you run the following commends (separately)?
iwconfig
ifconfig

Yeah, I have the Edup adapter. Here are the screens for those commands. (With the dongle plugged into the usb hub)

That's interesting.  Your WiFi seems to be there, but it got a weird name "wlxe84e066f8f24".  I'll have to try to figure that out.

I assume that if you unplug the WiFi adapter and rerun iwconfig, that goes away?
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#32
I'm not sure why, but it seems that maybe "predictable network interface names" is turned off on your install.

Try this.

Run
sudo raspi-config
- Choose Network Options
- Choose the 3rd option that's "Network Interface Names" and then turn on "predictable"

Reboot.

Then show what iwconfig looks like.
We may have to remove an entry that got stuck in the rules. Show us the output of

ls /etc/udev/rules.d/
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#33
(11-05-2019, 06:20 AM)Flavor Wrote: With the WiFi and keyboard on the hub, you can also do these...

sudo raspi-config
- I don't remember exactly, but it's like Networking/WiFi and then you set the country and then your SSID and password.

Then, run
sudo /home/pi/RetroPie-Setup/retropie_setup.sh
- Then Configuration/WiFi
- Then what does it show at the top of the screen?  If you select CONNECT, does it show a list of WiFi routers?

I've just done this, and here's what I got. It shows my IP address now and my SSID, but probably only because I've just entered it. When I hit Connect, I still get the same error. Here's the results for iwconfig without and with the dongle connected.


Attached Files Thumbnail(s)
           
Reply
#34
(11-05-2019, 06:32 AM)Flavor Wrote: I'm not sure why, but it seems that maybe "predictable network interface names" is turned off on your install.

Try this.

Run
sudo raspi-config
- Choose Network Options
- Choose the 3rd option that's "Network Interface Names" and then turn on "predictable"

Reboot.

Then show what iwconfig looks like.
We may have to remove an entry that got stuck in the rules.  Show us the output of

ls /etc/udev/rules.d/

I've enabled predictable network interface names, here's the new iwconfig output and the other picture you've requested.


Attached Files Thumbnail(s)
       
Reply
#35
Wait, I think it's connected now. My WiFi recognizes a device called retropie, and the dongle is blinking green. I still get the same error when I try to connect to WiFi, but I guess it doesn't matter if I'm connected anyways. I'll try and SFTP a file over and update in a minute.

Edit: It worked! Not sure what did it, but it did. Thanks again!
Reply
#36
(10-31-2019, 03:07 AM)Flavor Wrote:
(10-30-2019, 03:03 PM)Happyhaha2000 Wrote: Alright, I've placed an order for the dongle. Any idea how to get the fan to work? Or is it already working automatically? Maybe it's just so quiet I can't hear it, but I thought that maybe I would need to do something similar to what I did to get the L2/R2 buttons to work.

Yes.  First, make sure you've followed the soldering instructions at https://docs.google.com/document/d/1GkmF...p7xxr08l5l

There is (IN THEORY) a new/easier way and our older/standard way to do it.  Read the "Note" there as to why it's not as simple as it should be.

Old/Standard
See https://github.com/TheFlav/rpi-fan
Code:
cd /home/pi/Freeplay/
git clone https://github.com/TheFlav/rpi-fan.git
cd rpi-fan/
sudo cp run-fan-service /lib/systemd/system/run-fan.service
sudo systemctl enable run-fan.service

Then reboot to have the fan service run at bootup.

New/Easier
Note:  This new/easier way should be fairly simple, but there has been a bug in the gpio-fan overlay module that ships with Raspbian (and RetroPie).  I actually am not sure if the latest update fixes this yet or not.  If you have the old overlay module, the fan will actually be ON when you boot up and then turn OFF if the CPU gets too hot.  Yeah, that's not very useful.  

For the time being, you can do this, to get/compile/install the new overlay module.

Code:
wget https://raw.githubusercontent.com/raspberrypi/linux/rpi-4.19.y/arch/arm/boot/dts/overlays/gpio-fan-overlay.dts
sudo dtc -W no-unit_address_vs_reg -@ -I dts -O dtb -o /boot/overlays/gpio-fan.dtbo gpio-fan-overlay.dts

Code:
sudo nano /boot/config.txt
add one line that looks like this
Code:
dtoverlay=gpio-fan,gpiopin=40
You could also change the temperature at which the fan switches on.  The parameter is in millicelsius, and the default is 55000 (AKA 55 degrees celsius).
Code:
dtoverlay=gpio-fan,gpiopin=40,temp=60000

Also, I would say that the default gpio-fan temp is somewhat aggressive.  It will basically run the fan anytime the CPU is in use at all.  I think 60C or 65C may be better if you don't want the fan to run as often.   Our "old" way of doing it would turn the fan on at 60C and then turn it off when it got down to 55C (if I recall correctly).  The gpio-fan module will turn the fan on at the specified temp and then turn it off at 10C less than the turn on setting, and this would be 55C on and 45C off by default.

Alright, I've done the newer option, but I'm not sure that I've done it all right.  I've entered the codes you gave me and added "dtoverlay=gpio-fan,gpiopin=40,temp=60000" to the config.txt. The fan should only turn on at 60C now, right? and then turn off at 50C? Is there a way I can check this to make sure that it works? Does the fan also turn on when I boot up? I think I can hear it whirring but it's hard to tell.
Reply
#37
If it turns on when you boot up, that's likely a problem.  

Did you do this part?
Code:
wget https://raw.githubusercontent.com/raspberrypi/linux/rpi-4.19.y/arch/arm/boot/dts/overlays/gpio-fan-overlay.dts
sudo dtc -W no-unit_address_vs_reg -@ -I dts -O dtb -o /boot/overlays/gpio-fan.dtbo gpio-fan-overlay.dts
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#38
(11-05-2019, 08:02 AM)Flavor Wrote: If it turns on when you boot up, that's likely a problem.  

Did you do this part?
Code:
wget https://raw.githubusercontent.com/raspberrypi/linux/rpi-4.19.y/arch/arm/boot/dts/overlays/gpio-fan-overlay.dts
sudo dtc -W no-unit_address_vs_reg -@ -I dts -O dtb -o /boot/overlays/gpio-fan.dtbo gpio-fan-overlay.dts

Yeah, that's the first thing that I did. I'm not sure that it's turning on when it boots up, that could just be a clicking sound made by something else. Hard to tell if the fan is going or not.
Reply
#39
You can post the results of
gpio readall


That will tell us if it (GPIO 40) is on or off, I think.

If you want to heat the system up (and show the temp and status of GPIO40), you can do this...


Code:
sudo apt-get install stress
while true; do vcgencmd measure_clock arm; vcgencmd measure_temp; gpio read 40; sleep 10; done& stress -c 4 -t 900s
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#40
(11-05-2019, 08:24 AM)Flavor Wrote: You can post the results of
gpio readall


That will tell us if it (GPIO 40) is on or off, I think.

If you want to heat the system up (and show the temp and status of GPIO40), you can do this...


Code:
sudo apt-get install stress
while true; do vcgencmd measure_clock arm; vcgencmd measure_temp; gpio read 40; sleep 10; done& stress -c 4 -t 900s

pi@retropie:~ $ gpio readall
+-----+------+-------+      +-----+------+-------+
| Pin | Mode | Value |      | Pin | Mode | Value |
+-----+------+-------+      +-----+------+-------+
|   0 | IN   | High  |      |  27 | OUT  | High  |
|   1 | IN   | High  |      |  28 | IN   | Low   |
|   2 | IN   | High  |      |  29 | IN   | Low   |
|   3 | IN   | High  |      |  30 | IN   | Low   |
|   4 | IN   | High  |      |  31 | IN   | Low   |
|   5 | IN   | High  |      |  32 | IN   | Low   |
|   6 | IN   | High  |      |  33 | IN   | Low   |
|   7 | IN   | High  |      |  34 | IN   | High  |
|   8 | OUT  | Low   |      |  35 | IN   | High  |
|   9 | ALT0 | Low   |      |  36 | IN   | High  |
|  10 | ALT0 | Low   |      |  37 | IN   | Low   |
|  11 | ALT0 | Low   |      |  38 | IN   | Low   |
|  12 | ALT0 | Low   |      |  39 | IN   | Low   |
|  13 | ALT0 | Low   |      |  40 | OUT  | Low   |
|  14 | IN   | High  |      |  41 | IN   | High  |
|  15 | IN   | High  |      |  42 | IN   | High  |
|  16 | IN   | High  |      |  43 | IN   | High  |
|  17 | IN   | High  |      |  44 | ALT2 | High  |
|  18 | IN   | High  |      |  45 | ALT2 | High  |
|  19 | IN   | High  |      |  46 | IN   | High  |
|  20 | IN   | Low   |      |  47 | OUT  | High  |
|  21 | OUT  | High  |      |  48 | ALT0 | Low   |
|  22 | OUT  | High  |      |  49 | ALT0 | High  |
|  23 | IN   | High  |      |  50 | ALT0 | Low   |
|  24 | IN   | High  |      |  51 | ALT0 | Low   |
|  25 | IN   | Low   |      |  52 | ALT0 | High  |
|  26 | IN   | High  |      |  53 | ALT0 | High  |
+-----+------+-------+      +-----+------+-------+
pi@retropie:~ $


Here's what I got for doing that. OUT means off?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)