Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPZ image not booting - two green blinks
#1
I just got my RP Zero W, SD Card, HDMI Adapter.  I don't have my Freeplay kit in the mail yet but I thought I would take the opportunity to get the PI working.

I burned the "Freeplay_Zero_18011901.img" image using Win32DiskImager and attempted to boot.  The green light blinks twice and doesn't boot which would indicates it's a prob with the image.  

I downloaded a Raspian image and burned it and it booted up fine so the PIZW works ok.

Repeating again with the FPZ image and two green blinks and then nothing.

I tried another SD card.  Tried using Etcher instead of Win32DiskImager with the same results.

Is there any other way to to troubleshoot the image provided?

Thanks so much.
Reply
#2
Just a follow up. I tried the "Freeplay_CM3_18010801.img" as well and it behaves the same as the "Freeplay_Zero_18011901.img". Two green blinks and then nothing.
Reply
#3
Well, the CM3 image would likely not work, but that's not the issue.

I think the Freeplay_Zero_18011901.img should work just fine. I can't test it right at the moment, but you could go back to the previous img in the archive folder. I doubt that's the issue, though.

We do turn off the LED at boot. It's internal once you build, so it's fairly useless. Are you connecting to HDMI? Is the LED on the Pi itself the only indicator that you're using to tell if its booting properly?
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#4
I am connected to HDMI and have flashed and booted Raspian and RetroPi 0/1 4.3 image. Are there other files changes I can make to RetroPi to make it work with the FreePlay Zero?
Reply
#5
There is a chance that some of the models that we make in Config.txt don’t work well with your TV. You could try commenting out the HDMI lines in there. We force a specific resolution, so that the LCD doesn’t look stretched at all.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#6
I'm using a monitor but I will poke around in config.txt
Reply
#7
You can let it auto detect the monitor. That should be fine for now.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#8
Your /boot/config.txt should look similar to https://github.com/TheFlav/Freeplay-Supp...config.txt

The top is "stock," but you can find our mods after the
# BEGIN FREEPLAY MODS
line.

For your testing, I think you could just
==change==
hdmi_force_hotplug=1 #these HDMI lines will try to set up 1024x768 (you can remove them if you have problems playing via HDMI)
HDMI_FORCE_MODE=1
hdmi_group=2
hdmi_mode=16
hdmi_drive=1 #Normal DVI mode (No sound) (2 for HDMI with sound)
==to==
hdmi_force_hotplug=1 #these HDMI lines will try to set up 1024x768 (you can remove them if you have problems playing via HDMI)
#HDMI_FORCE_MODE=1
#hdmi_group=2
#hdmi_mode=16
#hdmi_drive=1 #Normal DVI mode (No sound) (2 for HDMI with sound)
====

Note that you could try hdmi_force_hotplug on or off, but I think there's no reason to let it try composite video.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#9
Thanks all. Confirmed that un-commenting:

hdmi_force_hotplug=1

enabled so I can test on my HDMI monitor.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)