Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
lr-gpsp not (only partially) working
#11
I did a bit more digging and went down a bit of a rabbit hole.

There's a file called /opt/retropie/libretrocores/lr-gpsp/game_config.txt
It should be located at /home/pi/RetroPie/roms/gba/game_config.txt, because that's where lr-gpsp will look for it.

It ONLY gets used if there ISN'T a compiled-in entry for the game you're loading.  In the code snippet, load_game_config_over tries to find the compiled-in entry and load_game_config reads from the game_config.txt file.
Code:
   if ((load_game_config_over(gamepak_title, gamepak_code, gamepak_maker)) == -1)
      load_game_config(gamepak_title, gamepak_code, gamepak_maker);

Well, I edited gpsp_libretro.so so that it didn't include an entry for the file I was having problems loading.  Then it loaded /home/pi/RetroPie/roms/gba/game_config.txt, but it still crashes in the same way.  I guess that means that game_config.txt isn't the problem (or maybe that the settings in it aren't correct).

Here is the output leading up to the crash.
Code:
[INFO] [Joypad]: Found joypad driver: "udev".
[WARN] [udev]: Full-screen pointer won't be available.
[INFO] ALSA: Using signed 16-bit format.
[INFO] ALSA: Period size: 384 frames
[INFO] ALSA: Buffer size: 1536 frames
[INFO] Loading history file: [/opt/retropie/configs/gba/content_history.lpl].
[INFO] Loading history file: [/opt/retropie/configs/gba/content_favorites.lpl].
[INFO] Loading history file: [/opt/retropie/configs/gba/content_music_history.lpl].
[INFO] Loading history file: [/opt/retropie/configs/gba/content_image_history.lpl].
Segmentation fault
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#12
(02-03-2018, 02:51 AM)jakejm79 Wrote: I think its just an issue of rom compatibility (or lack of) and lr-GPsp. Try a known working one like Super Mario Kart Advance or something.

The rom isn't incompatible. I can load it by launching through retroarch (as I described in my posts before).
Reply
#13
My point was that if another (known working) game loads then it appears to an issue with the emulator/front end/rom and not specific to the FPZ and therefor the thread belongs in the relevant forums for those and not here. If you are having issue loading a ROM that would otherwise load and run fine on a generic Retropie build and for some reason just fails on the FPZ then it would belong here.
Reply
#14
(01-31-2018, 05:18 PM)maddin1502 Wrote: I can't load any GBA rom with lr-gpSP. My bios file is valid, I tested it!

what I know so far:
  • gpSP (without lr-) is working fine, but it's not optimized for retroarch (no hotkeys)
  • lr-mgba is no option, the PiZero is not powerfull enough
  • lr-vba-next is not supported on PiZero
    I modified the retropie-setup script to install it anyway -> PiZero is not powerfull enough...
  • lr-gpSP can't load any rom -> black screen -> back to menu (attention: only if lr-gpSP is started through emulationstation menu)
  • lr-gpSP works when started through retroarch !!!
    - run retroarch from retropie menu
    - setup correct path to libretro cores
    - load core -> select lr-gpsp
    - load content -> select GBA rom file
    - its working!!! nice performance (slowdowns are rare) - but why  Huh
How can I fix it to work throught emulationstation menu? Is it an FPZ/FPCM3 issue?


Edit:
In some posts from other forums dynarec (dynamic recompiler) was mentioned as a problem... 
After I launched lr-gpSP (and loaded a game) directly through retroarch, I disabled dynarec and stored (overwrite) the settings for the core AND game.
Now, I tried to launch lr-gpSP from emulationstation... my changes had no effect... still black screen and fallback to the menu... so I think dynarec is not the problem (or maybe my settings are not loaded correctly). It would be illogical if dynarec depends on the launching method...

Hi, 
seems like I am having the same issue with GBA Roms (lr-gpSP can't load any rom -> black screen -> back to menu) ... and "lr-mgba" is to slow. Have not tried retroarch or gpSP (without lr-) yet though ... have you found a soulution?
Reply
#15
Esteban_Pueblos, you need to have the exact BIOS file in there. Please see https://github.com/retropie/retropie-set...oy-Advance
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)