Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Brightness controller (No Controller Detected)
#1
Got the brightness control mod for my Freeplay Zero installed today but when I attempt to enter the brightness control menu I get a message stating no brightness control mod detected. I made sure to enable IC2 and reboot and still nothing. I tore it back apart and verified continuity to the correct pins on the Pi with a voltmeter so it doesnt appear to be a connection issue. Could the controller be bad or am I missing something. Any suggestions? Fresh install of image: Freeplay_Zero_18070601.img.gz.
Reply
#2
That all sounds like you're doing it properly. The latest image should have the I2C all set up already. If you are able to SSH in or hook up a keyboard, let me know. I have some commands that I'd like you to try...

The first would be:
ls /dev/i2*

That should list the i2c busses. If there's nothing there, that would definitely be an issue. If there is something there, it should be like /dev/i2c-1.

I don't recall offhand if i2cdetect is on that image. If it's not, you might need to install it with:
sudo apt-get install i2c-tools

After that, you could try:
sudo i2cdetect -l
sudo i2cdetect -y 1
sudo i2cdump -y 1 0x62


Let me know if you could try those.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
Here's the fix (I think).

If you can SSH (or keyboard) in, run these two commands.

cd /home/pi/Freeplay/setPCA9633
make

Then you should be able to run the brightness setting menu item.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#4
(08-09-2018, 09:43 AM)Flavor Wrote: Here's the fix (I think).  

If you can SSH (or keyboard) in, run these two commands.

cd /home/pi/Freeplay/setPCA9633
make

Then you should be able to run the brightness setting menu item.


Thank you!!! This worked. I did not get a chance to try what you mentioned in the previous post as I have been sick for the past few days (still am) but I did try this first and it worked! So you can add that to the next build or possibly the install notes for the brightness controller with some confidence that it will indeed help/correct the issue.
Reply
#5
Thanks for letting us know, automiketic! We're working on a new SD image with this fix (among other things).
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)