Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED - PSX troubles
#1
Not sure how much help I can get here, but I'll explain.

So I saw there was a Freeplay driver update that was supposed to smooth out the frame rates, so I decided to add it to my existing 4.3 image. It did not work however. I saw the newest inage has this update, so I wiped the SD card and installed the newest Freeplay image. Same thing, driver didn't work...

So I went back to 4.3, and set up my emulators so everything is working fine. PlayStation however... Idk why, but every game I launch, after the run command shows up, it completely freezes. Holding the power switch does not shut it off, so I have to disconnect the battery every time. I'm using PCSX-ReArmed, the non libretro core because it has much better performance on the Pi Zero. It worked flawlessly before I moved to 4.4 for the display driver update, and I can't understand why it does not work anymore. Very frustrating.

If anyone has any ideas, let me know. My boot config and fbcp configs are unchanged, except for these added lines to boot config:

hdmi_cvt=320 240 60 1 0 0 0
hdmi_mode=87

I used these settings previously on my old 4.3 image and everything worked great. I should add that the lr core works fine, but the performance is not great enough to work on a Pi Zero.

Edit: this is what I see when I select a game:

http://imgur.com/97frpPi
Reply
#2
Got it working finally!

I followed this guide to get it working. It turns out too that the display resolution is too high, and emulationstation doesn't know what to do with pcsx after launch

EDIT: I spoke too soon. After installing the rest of the Freeplay stuff (mk_arcade_joystick, adding Freeplay section in boot/config.txt) it is still not working. It works fine through HDMI but the display on the FPZ is frozen solid on the run command screen and never updates.
Reply
#3
(08-21-2018, 05:44 AM)Ordinary Vanity Wrote: Got it working finally!

I followed this guide to get it working. It turns out too that the display resolution is too high, and emulationstation doesn't know what to do with pcsx after launch

EDIT: I spoke too soon. After installing the rest of the Freeplay stuff (mk_arcade_joystick, adding Freeplay section in boot/config.txt) it is still not working. It works fine through HDMI but the display on the FPZ is frozen solid on the run command screen and never up
It probably has to do with the possible resolution change between emulation station and PCSX. The display drivers don't play nicely with resolution changes so you may have to look into the config file and set the resolution to match your /boot/config.txt option.
Reply
#4
I figured it was something like that. I just don't know how to do it. The pcsx config doesn't have any option for resolutions. :/
Reply
#5
So I've set /boot/config.txt to display 320x240. I've set pcsx to display at 320x240. Everything is displaying at that resolution. Idk what else to do because it is still not working :/

EDIT: Finally!!!

Setting the frame buffer in /boot/config.txt to 640x480 fixed it. I guess 320x240 is too low or not supported?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)