Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no audio after trying to play thru hdmi
#1
I connected my freeplay zero to the tv, and went into the audio section of retropie and selected HDMI output. I now no longer get any audio from the built in speaker or HDMI. I have gone back into that menu and selected auto and also default with no changes. How can I get audio to play on the built in speaker again?
Reply
#2
After switching it back, try rebooting with the HDMI unplugged. Then, if the speaker is working fine, plug the HDMI back in.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
By the way, if you want audio output through the HDMI, edit the /boot/config.txt file and change

hdmi_drive=1
to
hdmi_drive=2

Then, what you did originally will likely work to get HDMI output (or may just work if you boot up with HDMI plugged in since you have it set to auto).
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#4
(12-09-2018, 06:32 AM)Flavor Wrote: After switching it back, try rebooting with the HDMI unplugged.  Then, if the speaker is working fine, plug the HDMI back in
ok, that restored audio to the built in speaker Thank you. If I change the config.txt HDMI exception line will I need to modify it everytime I want to switch from the tv to built in audio?
Reply
#5
(12-09-2018, 06:36 AM)wade1234 Wrote: ok, that restored audio to the built in speaker Thank you. If I change the config.txt HDMI exception line will I need to modify it everytime I want to switch from the tv to built in audio?

No, you should not. It's mainly there to make the HDMI also work on monitors that do not support audio (which is getting more rare I think).
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#6
(12-09-2018, 06:43 AM)Flavor Wrote:
(12-09-2018, 06:36 AM)wade1234 Wrote: ok, that restored audio to the built in speaker Thank you. If I change the config.txt HDMI exception line will I need to modify it everytime I want to switch from the tv to built in audio?

No, you should not.  It's mainly there to make the HDMI also work on monitors that do not support audio (which is getting more rare I think).

That all worked thank you for the help, I really like the product and will recommend it to my friends!
Reply
#7
I figured I'd just piggyback on this thread as i am experiencing the same issue .  I uncommented hdmi_drive=2  in my config file.  When I plug the HDMI in and fire up the device the speaker disengages but no sound comes out of the tv.  Any other ideas on how to get audio working?  I've messed around with a lot of different sound settings to no avail and now i get a message failed to find mixer element.
Reply
#8
There's a bunch of RetroPie audio info at https://github.com/RetroPie/RetroPie-Set...und-Issues

(02-21-2019, 06:20 PM)safe_as_milk Wrote: I uncommented hdmi_drive=2  in my config file.

Do you have multiple hdmi_drive lines in your config, by any chance? If you just uncommented that, there is likely hdmi_drive=1 later in the config.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)