Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Troubleshooting WiFi access
#1
I have a CanaKit WiFi dongle which I have used to connect Pi3 units to the network before. Connecting my completed CM3 device to the USB hub, I can't get on to the network. The dongle sees the network, but the system just rejects the login.

- I tried exchanging keyboards as the first one was one of those little tiny things with a shift key on only the left side, but that didn't help.
- I re-checked accessing the network on my phone by re-entering credentials and it worked fine.

[Image: H2ELbHu.jpg]
Reply
#2
New Raspbian version require user to set there country before being able to connect to WiFi network.
To do so, go to Retropie > Raspi-Config > Localisation Options > Change Wi-Fi Country

Hope this will help Smile
Reply
#3
That definitely worked for my cellphone hotspot and I got the scraping done. I'll check again for the home network. It's possible that the low power condition prevented the caps lock LED on the keyboards from illuminating.
Reply
#4
What kind of encryption do you use in your local network?
Reply
#5
WPA2 on a 2.4/5.0 1900AC. I tried at home again with no luck. I don't think the USB hub operating unpowered would be a problem as I did get it to connect to the iPhone. It's just very odd that it didn't work on the home network.

edit: I'm putting this in my toolkit. It's not good to come up short with only microUSB chargers. https://www.amazon.com/Outtag-Switching-...0771LC63X/
Reply
#6
Maybe a solution : https://joshtronic.com/2017/01/29/unable...-in-linux/

Quote:I had noticed that I was running both 2.4GHz and 5GHz bands with the same SSID instead of splitting them out. First time owning one of these routers, but I know at the office we have the bands split. So I gave each band it’s own SSID.
Reply
#7
Is the root password not the default 'raspberry'?
Reply
#8
If you are talking about SSH, 'root' is disable by default, you have to edit '/etc/ssh/sshd_config' to allow root login.
The step is needed SSH and local login, you need to set 'root' password by running 'sudo passwd root'.

I wrote this by memory, I hope I don't miss something.

The part "Unable to connect to wifi after suspend" from the blog post is not needed.
Reply
#9
(04-19-2019, 01:24 PM)Porcinus Wrote: If you are talking about SSH, 'root' is disable by default, you have to edit '/etc/ssh/sshd_config' to allow root login.
The step is needed SSH and local login, you need to set 'root' password by running 'sudo passwd root'.

I wrote this by memory, I hope I don't miss something.

The part "Unable to connect to wifi after suspend" from the blog post is not needed.

Ah. So it's primarily the split ID, you think?

I dunno how I want to go about fixing that, tbh. Hmm.
- I've already done what I wanted to do with the device in connecting and downloading all the scraper data. This is more about understanding the problem rather than making a pratical fix.
- I'd probably rather have both bands using the same login in the long-term (different authentication would confuse guests).
- That still might be worth trying out.
- But I might still get a second or third external WiFi adapter to have on hand as well.


Regarding root:
It's not for ssh remote access. I'm just leaving emulation station and need sudo access on the command line.
Reply
#10
This is a possibility, I have no way to check this on my side :/
I don't really know if the problem can come from the shared SSID or the credentials itself.

For root, in your case, you should just need to set a password and run 'su' to get logged as root
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)