Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Buttons not working on pico-8 v0.1.12c
#1
When I run pico-8 v0.1.12c on my Freeplay CM3, the buttons and dpad are not working. I got this error message : 

the path /dev/dri cannot be opened or is not available

Maybe someone could help?
Reply
#2
I haven't tried it myself, but others have asked about it. If you do figure it out, please post here and let others know how to set it up on the Freeplay CM3.

I don't know where that error code comes from. It "seems" like it is looking for the joystick device, but that "/dev/dri" is incomplete. I guess that some config file for Pico-8 has /dev/dri listed in it.

On the Freeplay CM3, if the joystick is working in the main Emulationstation menu, that means it's set up as /dev/input/js0 and that's what other programs should read as the default first joystick. I don't know enough about what Pico-8 does, but I would assume that it would read this joystick.

Here are some links that may prove helpful (for anyone that shows up here):
https://www.lexaloffle.com/bbs/?tid=3935
https://www.lexaloffle.com/pico-8.php?#getpico8
https://www.lexaloffle.com/info.php
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
Can it be possible that video output driver (renderer) is not set right, when googling "/dev/dri", most of the first result are related to video card.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)