Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using splash screens on boot up
#1
I am attempting to use a custom boot splash screen and have also contacted the freeplay Facebook page and upon looking into this we were not able to locate a fix to when using the custom splash screen, which is a mp4 file, when loading the system locks up and will not boot and hard reset is needed to get into the system. Does anyone have any ideas how to fix this?
Reply
#2
I found this...

GitHub RetroPie Splash

and another tutorial

Hoping it helps. It is quite straight forward I think.

Big Grin

Edit: if you broke something, just burn a new image and try again.
Reply
#3
I tried using this option and when doing so it keeps locking and will not load into the system
Reply
#4
What driver are you running?
Also helps to know what hardware you're running. Zero? CM3? I assume CM3, running one of the Experimental drivers.

And also- when it "locks up", have you tried plugging in via the HDMI-out to see that it's truly locked up?
If the screen is solid white when booting up and trying to play your video splash, and the HDMI still shows a picture- there is a reason this is happening, but I can't seem to find the fix.

Reason:

If you're running one of the Experimental drivers on the CM3, they do not play well with OMX, which is what is used for a video splash.
As soon as the video is called up in the boot process, the video- your .mp4- will crash the driver, and present a constant white screen.
Meanwhile, HDMI output is still active, and you can hook up to a TV to change either back to "Default" driver, or go back to a normal splash picture.
Picture splash screens work fine. Video splash screens crash the Experimental drivers.
However, Video splash screens work just fine under the "Default" driver. I just set mine up on my FreePlay Zero running "Default" LCD driver, no problems.
If you're having issues running a video splash under the "Default" driver- then it is likely an issue with the video you're trying to use, or you may just need to revert to a clean install.

All of this is of course assuming you're on a CM3, and running any of the drivers besides the "Default" one.
Reply
#5
I know someone also asked for this problem some times ago but I don't remember who :S
To my remember, this post did also pointed out that the problem could come from OMX.
If I found back the post, I will add the link here.
Reply
#6
That was me, haha. It was a "sub-problem" in our big discussion on the ili9341 driver.

I am actually going to ask Juj if there's any input on that.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)