Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Did I semi-brick my Freeplay board? (USB/HDMI issues)
Hey all! Got a bit of a weird issue going on with my CM3 build where the HDMI and USB ports aren't being recognized, though they were working before.
Should first note that I did not build my CM3 myself, I ordered it from the team over at RetroModding earlier this year, and they did a phenomenal job with the build.

In using the handheld, there have been times which I needed to disconnect the battery due to either not being able to control the device (by either menu or by attempting a force shutdown on the system with the power button) or in instances when I would transfer files over using an app on my PC to the SD card, only for the 'last time written' to be off compared to the Pi and needing to go through and verify file integrity, but then not proceed afterwards. In doing so, I was always aware that data corruption on the card could be a possibility and was not ever worried in the event that I needed to reflash the system and needed to reinstall the packages for the add-ons like the L2/R2/Hotkey buttons and the fan that was added on. 

As this was months ago, I don't remember exactly what had occurred, but after one of these instances of disconnecting the battery, I think I may have shorted something out and damaged the board in some capacity when doing so. My first indication was that it now takes over 15 seconds for the board to now power on, when I think it took somewhere between 5-10 seconds before. Not a big deal to me imo, but is still worth mentioning as it is a change from the previous norm. After booting the device back up, I tried to do HDMI output and did not get a picture out out from the device. Figured that it could be related to the LCD settings I was changing, so I paid it no mind at first. However, when trying to use my TP-Link USB Wi-Fi device I was using before, the device was no longer being picked up by the Pi, it would state that there was no WLAN0 device available.

As this was still a few months back, I didn't pay it much mind as I still had a mostly functioning handheld. This weekend, I had some free time open up and I had just gotten my hands on a tri-wing screwdriver set off of Amazon, so I wanted to open up the device to see if I could find any issues with the main board or connections, but I could not find any issues whatsoever.

While I still had it disassembled, I grabbed a secondary SD card to flash with the latest version from the Google drive using Etcher and proceeded to test the device once again (powered over Micro-USB) - even from the first two boots of the device, HDMI-out did not work even though I was getting an output from the screen. Attempting to boot without the screen connected produced the same results, nothing over HDMI. I then grabbed my USB WiFi device along with two different keyboards (one wireless, one wired) and attempted to see if the USB connection would recognize anything, and the only result I got was with the wired keyboard lighting up to show that it was receiving power, but even going into configure the controls none of the keys would register on the system.

As the add-on board for the additional buttons and fan were soldered onto the board (quite cleanly, I might add), the only thing I was unable to try out was to reseat the CM3 board into the socket, as I was afraid that I would damage the add-on board on top of it. If it is possible to remove the CM3 without removing the add-on board, I can definitely give that a try after removing the heat sink from the board and see if conditions improve at all.

At this point, I'm looking for any other recommendations I could try out before throwing in the towel and ordering a new CM3 kit, though I'm worried that in trying to salvage the add-on board that I'll botch things up worse than it is now. I'd appreciate any and all advice, thank you!

EDIT: Success! I managed to unseat and reseat the CM3 module and the issues that I was experiencing with the USB and HDMI port seemed to vanish! Very strange for it to have happened in the first place, it must have gotten dislodged somehow while still maintaining most of the device's functionality. In any regard, I am very excited to have fixed it, and will leave this post for others in case they run into the same issues I did! Cheers!
Glad to hear you've resolved your issues! This is great news!
That's nice to know how you did solve the problem Smile

Most of the times, problems come from false contact on the Compute Module.
I think it is because of the mass of the handheld. Since it is really lightweight, there are almost nothing to absorb vibrations from the speaker and it can end up messing with the connection.

Forum Jump:

Users browsing this thread: 1 Guest(s)