Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Faulty analog stick
#1
Hi Everyone

so basically the up direction on my analog stick is not working but the down direction works perfectly... since they are the same axis... could anyone confirm that this means the analog stick itself is faulty... or is there something else it could be, as I don't understand how it could be anything else, seen as how they share the same connection and operate off the same line of code... right???

Thanks
Reply
#2
I have seen a misconfiguration act like that before. Can you post the output from this command?
cat /etc/modprobe.d/mk_arcade_joystick.conf

Maybe you already did this...
In the /home/pi/Freeplay/mk_arcade_joystick_rpi directory, you can run 'make config' and it may help you get it configured properly.

So, it'd go something like this (assuming the system is connected to the internet):

cd /home/pi/Freeplay/mk_arcade_joystick_rpi
git pull
./install.sh

Then, I'd probably reboot. After the reboot,
cd /home/pi/Freeplay/mk_arcade_joystick_rpi
make config

See how that works.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
(12-19-2019, 03:31 AM)Flavor Wrote: I have seen a misconfiguration act like that before.  Can you post the output from this command?
cat /etc/modprobe.d/mk_arcade_joystick.conf

Maybe you already did this...
In the /home/pi/Freeplay/mk_arcade_joystick_rpi directory, you can run 'make config' and it may help you get it configured properly.

So, it'd go something like this (assuming the system is connected to the internet):

cd /home/pi/Freeplay/mk_arcade_joystick_rpi
git pull
./install.sh

Then, I'd probably reboot.  After the reboot,
cd /home/pi/Freeplay/mk_arcade_joystick_rpi
make config

See how that works.
So my system isn't connected to the internet... how would I do that? sorry I'm a noob
Reply
#4
For now, if you have a USB keyboard, just try this. (if you can connect to a HDMI monitor/TV, that can be easier to read/photograph)

Plug in the keyboard. Boot up the system. Hit F4 on the keyboard. Type the following command.
cat /etc/modprobe.d/mk_arcade_joystick.conf

Post a photo of the screen.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#5
Photo 
hi flavour

sorry this is the only way I can send you code without having to type it all out hope its clear enough

also my system is not connected to the internet

   
Reply
#6
(12-19-2019, 06:58 AM)Ryan94 Wrote: hi flavour

sorry this is the only way I can send you code without having to type it all out hope its clear enough

also my system is not connected to the internet

Any ideas then?
Reply
#7
Well, that screen photo you sent me doesn't show the whole story. I was trying to figure out an elegant way to get all the info.

The NOT elegant way is this...

Instead of cat /etc/modprobe.d/mk_arcade_joystick.conf, do this command.
more /etc/modprobe.d/mk_arcade_joystick.conf

Since there is too much info to fit on the screen, more will break it up. You'll have to run the command, then take a photo, then hit enter, then take another photo, etc. I'm hoping this will get the line that I'm looking for.

The one I'm looking for is the ONLY (hopefully there isn't more than one) line that starts with the word options (as opposed to #options). So, there should be one that doesn't have a hash tag in front of it.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#8
okay so I used this command 

sudo nano /etc/modprobe.d/mk_arcade_joystick.conf

and then realised I had two lines uncommented so fixed that..it seems to have worked and i managed to register a + and - on the y axis in configure input, but it is still a bit fiddly but it will do... how ever now the controls only work in the RetroPie menu but not in the actual games... is this a quick fix thing or what?

here's the output from the other command you asked for if it helps...

                   

sorry about the poor quality

thanks
Reply
#9
After that, you probably need to re-define the controls in RetroPie.

At the main menu, hit START. Then choose CONFIGURE INPUTS (or something similar). Go through the whole thing. If you have a keyboard connected, it's easier, because you can hit the down arrow to skip the inputs you're not defining. At the end, it'll ask for the hotkey. If you want to use the power button, double-tap it there. Otherwise, maybe use SELECT as the hotkey button.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#10
At the command prompt, you can also use the following commands to test the joystick.

jstest /dev/input/js0
jstest --event /dev/input/js0
evtest
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)