CM3 no boot at all (no white screen)
Hi there,

I recently purchased the complete kit from retromodding that includes the shell, battery, speaker, etc. plus obviously the Freeplay CM3 and the Pi itself.

I'm trying to have it boot to HDMI out before I get too excited about fitting it into the shell. However, even that isn't working.

Most people on forums that I've searched are running into a "white screen" but I don't even get that far. With the battery, mini-HDMI, and micro-USB for power in connected, as well as the SD card loaded, pushing the power switch does nothing except make a high-pitched squealing sound like I'd expect from electrical flow.

The LED appears to function correctly (blue when battery is connected indicating charging, green when disconnected indicating full power), but bumping the switch does nothing to the LED. Holding it down causes my monitor to detect that power is going to the HDMI output but it does not actually send a feed, and removing pressure from the switch removes the signal.

I've tried flashing with both the RetroPie V4.6 and 4.5 for the CM3 which are available here:

Neither of those made any difference although they appear to have imaged correctly (As I've imaged plenty of flash drives for booting to linux in the past I'm reasonably confident of this).

At this point I'm well and truly out of ideas, particularly as there doesn't seem to be anyone else having this same problem, so it's difficult for me to troubleshoot.

Any advice would be much appreciated, and if you need further info please let me know and I'll provide it.
How long did you hold down the power button? It will take 5-10 seconds or so before the OS boots and takes over. That's when the front LED will turn green and you can let go of the power button.

Did the Raspberry Pi CM3 come with the bundle from Retromodding? If not, which compute module is it? It _HAS_ to be the Lite version with no built-in eMMC (either CM3 Lite or CM3+ Lite).

What program did you use to image the file to the SD card?
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )
Hi, thanks for replying!

I have been tapping the power button as I'm familiar with bump switches on, for example, the Nintendo DS. Holding down the switch results in a change in the sound of the high-pitched humming from a consistent sound to either no sound or a sequence of sounds (variously). The LED at the front does not illuminate, nor does the blue LED on top change colour.

Yes, the CM3 came with the bundle from Retromodding, so I assume it is the correct one.

Originally I simply used linux command line tools to flash the microSD; specifically `dd`, but I did reflash it using `parted` and `mkfs` to reformat before using `dd` again. When that didn't work, I formatted with `parted` and `mkfs` and then tried using Etcher via the GUI, which didn't work either. Is FAT32 a supported file system or is it possible that I need to format with a different one?
Nevermind, it seems to work now! I think the holding down the switch was the thing, when I was testing just now I had simply forgotten to reinsert the sd :/

Thanks for your help! I can proceed with the rest of my build now Smile
dd, Etcher, or even the Raspberry Pi Imager should all work. They do the same thing. They take the .img file and 'dd' it to the SD card. You do not need to have any partitions or filesystems on the SD card. Even if you do, they will get overwritten by the dd.

If you use dd, you need to dd to the SD card and not a partition on the card. It would be like
dd if=file.img of=/dev/sdc bs=4M
or some such (written from memory)

You would _NOT_ want to use of=/dev/sdc1 or any number following the device's letter.

Notice, also, that I used the .img file for dd. Etcher and the Raspberry Pi Imager should take the .img.gz and ungzip it to .img during the process. dd is pretty dumb, so it will allow you to give it a .img.gz file, but that won't work well in the end.

gunzip file.img.gz
then use dd as shown above

After you image 'to' the SD card using your Linux machine, what does the SD card look like? Once dd is complete, pop the SD out and then back in. What does 'lsblk' say? Does it show any partitions on the SD card?

How long did you hold down the power button? Do you ever see anything on the HDMI while you're holding the power button in the ON position (for like 10 seconds or so)?

Another thing to try is disconnecting the Raspberry Pi from the Freeplay board. Then, re-connect it. I have heard of rare times when this fixed odd problems.
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )

Forum Jump:

Users browsing this thread: 1 Guest(s)