CM3 i2c configuration
Hi all,

Posting to describe an i2c config issue I found while setting up my CM3 kit. I resolved it; just leaving a note that may help someone else. I have the CM3 board v1.5 with a non-plus compute module, no add-on boards installed.

I've already had many hours of enjoyment with this kit; thanks to the Freeplay team for making a cool product. Also congrats on launching the new Zero 2 hardware version!

I found i2c did not work on my build (integrated brightness controller wasn't recognized), but only with the newer SD images (dated after 12-May-20). The 'Freeplay_CM3_20051201' image worked as expected. The fix was to apply a different device tree overlay. Working from the 21110201 SD image, I replaced the default:




baudrate was set to 400000. i2cdetect then returned all the expected addresses, and brightness control worked.
I couldn't find an exact reason why this change was necessary, other than dtoverlay help text stating that 'i2c-bcm2708' is deprecated. Help is accessed by 'sudo dtoverlay -h <overlay>'.

Has anyone else encountered this?
I'm sorry that I didn't reply before.

This is good/correct info. They must have removed i2c1-bcm2708 at some point.
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )

Forum Jump:

Users browsing this thread: 1 Guest(s)