Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UPDATE FIXED Audio isue: lvl0 volumecontrol init failed to find mixer elements
#1
On my new Freeplay Zero build I am getting a error message of "lvl0 volumecontrol init failed to find mixer elements."  I've tried selecting auto, headphone jack, and hdmi audio output but the error is there for all options.  I formatted my sd card, wrote a new retropi image to it, and reinstalled everything on the Zero but the audio still isn't working,  I'm a novice with programing so any help you may offer please explain throughly.
Reply
#2
@djennerman I had this error message when I was messing around with some HDMI settings to get audio via HDMI. Did you have audio through HDMI before or changed some settings regarding audio in the init files?
If not, my current settings are as follows for native speaker output:
Audio device: PCM
Enable navigation sounds: on
Enable video audio: on
Omx player audio device: ALSA: HW,10

Actually, I don't get sound in the retropie menu, but ingame sound works fine. There is also no ingame sound for you?
Then we have to wait for Ed's reply, he knows stuff better than I do Big Grin
Reply
#3
I've been through all of the settings and into the config.txt file.  I've gone through all of the "fixes" off of forums and YouTube but none of it has helped.  The only time I had audio was the first ROM I installed and then all was lost after I added more.  Now that the power doesn't stay on is making me think there's something physically wrong with the FPZ board or the raspberry pi zero.
Reply
#4
UPDATE: I installed a fresh image of Freeplay Zero 17111701 to my FPZ and it powered on, booted up, and stayed on when powered through the FPZ board. So, that seems to have fixed the power issue. However, there still isn't any sound through the on-board speaker, headphone jack, or through hdmi. I haven't touched any settings in /boot/config.txt, or in Emulation Station this time around.
Reply
#5
PROBLEMS SOLVED UPDATE: The audio and power issues are solved. Like I stated above, the power was fixed with a clean image of Freeplay Tech. The audio was slightly less intuitive to solve. I started with plugging my damaged screen back in to get the FPZ off of the HDMI TV I was using for troubleshooting. I then disconnected the USB keyboard I was using in Terminal. Neither of these fixed the audio at first, but then I set the audio to headphone jack mode in Emulation Station's settings menu, that got the audio working though the jack, and when I unplugged the headphones the audio was transferred to the FPZ's on-board speaker. I surmise that using a USB keyboard along with HDMI output "confused" the settings. I can't be exactly sure, I kind of just bumble through electronics and get lucky.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)