Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Emulator console text
#1
Hey everyone, just got my CM3 build finished up and had a quick question.

Is there a way to make the console text in emulators bigger? 

For example when in the GBA emulator and using the hotkeys to switch slots I have no idea which slot I'm on because the text is so small that I can't read it.
Reply
#2
This is a really good question!  I've never tried, but I also wish the font was larger.  I did some searching.  I haven't tried any of this, yet.


Quote:use https://github.com/retropie/retropie-setup/wiki/Configuration-Editor
advanced configuration > configure libretro options > all/retroarch.cfg

set video_font_size = "24.000000"
from https://www.reddit.com/r/RetroPie/commen...font_size/


Quote:increase the font size in /opt/retropie/configs/all retroarch.cfg. search for this line:
Code:
video_font_size = "12"
and make it any size you want.you also can make these changes to it:
Code:
# Enable usage of OSD messages.
# video_font_enable = true

# Offset for where messages will be placed on screen. Values are in range 0.0 to 1.0 for both x and y values.
# [0.0, 0.0] maps to the lower left corner of the screen.
# video_message_pos_x = 0.05
# video_message_pos_y = 0.05
from https://retropie.org.uk/forum/topic/2694...overlays/3

Please let me know how that works for you.  I'd like to try it, but I'm pretty busy with some other stuff at the moment.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#3
Thanks for the reply! I actually figured it out!

Go to Retropie Configuration >
Retroarch >
settings >
Onscreen Display >
Onscreen Notifications >
and then change "Notification Size"

I used 37 to get it legible enough for me.

Also after doing that make sure to go back to the main Retroarch menu > "configurations" and SAVE THE CONFIGURATION! (that last part gave me an embarrassingly big amount of trouble, thought it was save on exit and was wondering why it wasn't working...)
Reply
#4
That's excellent news! Would you want to post a screenshot of the result here? That way people could see what we're talking about.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#5
(01-19-2018, 07:51 AM)Flavor Wrote: That's excellent news!  Would you want to post a screenshot of the result here?  That way people could see what we're talking about.

I tired to get one but sadly I couldn't figure out how to take a screenshot that includes the overlay in it. Couldn't grab a screenshot of the settings page either. 

Also probably doesn't help that I'm not too familiar with raspberry pis in general haha
Reply
#6
Well, you could just do a photo with your phone. That’s actually what I had in mind anyway. Smile
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#7
(01-19-2018, 09:40 AM)Flavor Wrote: Well, you could just do a photo with your phone. That’s actually what I had in mind anyway. Smile

That I can do Wink

Notification size: 37 with the black background on makes it much more readable!


[Image: K2WUlWk.png]
Reply
#8
(01-19-2018, 12:39 PM)thosepeoples Wrote:
(01-19-2018, 09:40 AM)Flavor Wrote: Well, you could just do a photo with your phone. That’s actually what I had in mind anyway. Smile

That I can do Wink

Notification size: 37 with the black background on makes it much more readable!

@thosepeoples thanks a lot for that guide. I also increased the font size to 30 and now it's much more enjoyable Smile

I have one additional question: how did you get the black background behind your notification texts?

Also, I figured that when you are in the submenu "settings", there is an option called "configuration". In it you find the option to "...save configuration on exit" that is OFF by default. If it was ON, it would have saved you the headache of finding out why the config wasn't saved even though you changed them.
Reply
#9
Oh man thanks for the save on exit tip, that's gonna be helpful!

[Image: MyFBiDd.png]

The black background is in the same settings page as the notification size, Enable set to on and everything to 0 for the black Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)