Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Freeplay Zero - Freezes after a while
#1
Hi!

i just got my freeplay zero and finished the case mods and had it fitted.
However, it seems that i've got some probably software related issues..

It boots just fine and sends me to Emulation station, but after a while in ES the whole system freezes and the only way to reboot it is by using the killswitch or pulling the power source.

Ive got a heatsink on the pi so i doubt its overheating

I did the soldering myself, have checked all the solder joints and cleaned it with isopropanol.
If i boot it up and start the included port the system can keep going without any issues, as long as im in hermes. However the hotkey toggle doesnt work and force quitting hermes makes the system freeze.

Ive tried this with both of the FPZ images with no success, also tried different SD-Cards, both which are verified as supported by Raspberry.

The reason i believe its software related is that it happens with or without the FPZ board connected. i also managed to catch an error msg from the pi while i was connected with ssh

Code:
kernel:[  158.570530] Internal error: Oops - undefined instruction: 0 [#1] ARM
kernel:[  158.579809] Process VCHIQ-0 (pid: 60, stack limit = 0xcf3f2188)
kernel:[  158.582404] Stack: (0xcf3f3e98 to 0xcf3f4000)
kernel:[  158.585004] 3e80:                                                       00000100 00000200
kernel:[  158.588802] 3ea0: cf3b4420 60000101 60000113 c09b2fcc ceaa8cdc cf580194 cf3f3edc cf3f3ec8
kernel:[  158.592684] 3ec0: c00567d4 c05d25c8 00000000 c09b2fcc cf3f3f64 cf3f3ee0 c04c1be0 c0056754
kernel:[  158.596538] 3ee0: 00000000 c08c27a8 00000000 c08b1778 cf3f3f4c cf3f3f00 c05d0b20 c0045ef4
kernel:[  158.600523] 3f00: c004f654 c0047d28 ceaa8cf0 cf580194 cf580020 ceaa8d88 000589f0 00000003
kernel:[  158.604411] 3f20: 0000000a cf580194 fff9fee9 ffffffff 00000000 00000000 00000000 00000000
kernel:[  158.608386] 3f40: cf3bb3a0 c09b2f80 c04c0a40 00000000 00000000 00000000 cf3f3fac cf3f3f68
kernel:[  158.612382] 3f60: c003e8fc c04c0a4c aaaaaaaa 00000000 aaaaaaaa c09b2f80 00000000 cf3f3f7c
kernel:[  158.616474] 3f80: cf3f3f7c 00000000 cf3f3f88 cf3f3f88 cf3bb3a0 c003e804 00000000 00000000
kernel:[  158.620612] 3fa0: 00000000 cf3f3fb0 c000fec8 c003e810 00000000 00000000 00000000 00000000
kernel:[  158.624823] 3fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
kernel:[  158.629193] 3fe0: 00000000 00000000 00000000 00000000 00000013 00000000 aaaaaaaa aaaaaaaa
kernel:[  158.650383] Code: f1080080 e1a00005 eb000459 e1a05000 (f10c0080)


I managed to get this error when running apt aswell (while trying to update incase there were any software related bugs that had been fixed)

Im close to trying with a RPi Zero WH but id rather not spend the money if possible
Reply
#2
Just did a little bit of research, and won't try to explain what VCHIQ is and will instead LINK to it instead. We have never run into this issue, so it sounds like it is probably a bad VideoCore portion of your Zero's processor, since you seem to have tried all of our normal plans of attack.

You may just have to end up buying a new Zero, though I'd first try booting, ssh-ing in, killing emulationstation and the display drivers with `sudo killall emulationstation` and `sudo systemctl stop fbcpOld.service`. Then try running a full system update/upgrade with `sudo apt update; sudo apt upgrade`. Reboot and give try again, but most people that have this kind of issue (freezing) usually solve it with a replacement Pi Zero.
Reply
#3
I will say that it's very rare, but we have had people solve problems by replacing their RPi Zero. I can't say what is the root cause, but it does seem like there are some time percentage of them (or any product really) that have issues.

It's hard for me to recommend spending the money on a new Pi, because the chances that one is bad are super low. On the other hand, I don't know what else it could be besides software. If you want something else to try, I'd recommend trying the base RetroPie SD image or any Raspbian image.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)