Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WS Flash Masta Not Showing Up (Zadig)

I just got some time to set up FLash Masta and im trying to use Zadig and it isn't coming up for me to format. I've watched the video tutorial but it hasn't come up. Are there any tips?

I tried different cables, i've tried different ports. I tried plugging it in and out several times for about an hour. Some help would be appreciated!
I split your post off from the thread that's more specific to the cart itself. I think this is more of a tech support question.

I wrote this up for someone else via email, but I think it's very good info to have here on the forum. I know that you have already said you tried some of this, but I want to have the info for anyone else that might come along.

The #1 reason this happens to people seems to be the USB cable. I have even had people try a couple different USB cables that failed and then bought a new one that worked. I think that some Micro USB cables are for charging only, and they don't work for data transfers. If you have any way to make sure the cable works on another device for data transfer from your computer to a device, that would help. Otherwise, try a few different cables.

After the USB cable thing, it is not a typical problem, but some users still experience some sort of USB incompatibility. We make and sell the Neo Geo Pocket and Wonderswan carts that use the same chip for USB. Most users don't have a problem, but we've sold enough to know that some small percentage of people do.

Once you know you have a good USB cable, try plugging it into different USB ports. There seems to be some incompatibility with some ports. I don't know why, but some users find that it fails on one of their ports but works on another.

Next is to try with or without a USB hub. Some people say that plugging directly into the computer helped and others say that plugging into a USB hub helped.

You said you're using Zadig, so I assume that you're on Windows. Does Windows make any sort of audio sound when you plug or unplug the device (like other USB devices would make)?

If I recall correctly, Zadig has a button to display all devices. You might need to use that to see the cartridge.

Also check your device manager to see if you can determine if the cartridge is showing up there. There is one situation where the cart could have lost its firmware and it could show up as an Atmel DFU device. This is very rare, but that could cause something similar to what you described.

Another great test is to try it on a different computer, especially if you have a Mac or Linux computer. This is what I suggest for you, XxKeeperxX, after you've done all the other stuff (that you may have done laready). What we REALLY want to know, at this point, is if the cart works properly or if there might actually be a hardware problem.

If it works on another computer, then the cart itself isn't bad, and we need to track down a software problem or incompatibility. If you hear a sound on Windows when you plug it in, that's a good indication that the hardware is okay but that another driver is causing a problem (or that it's in Atmel DFU mode).

See what you can track down, and we'll get things figured out for you.
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )
I just wanted to add that one of the people I helped via email just wrote back and said that they tried multiple USB cables and that turned out to be their problem. It's still odd to me that this is such a frequent occurrence.
Card Fighters' Clash 2 English Translation ( )
Neo Geo Pocket Flash Cart and Linker Project ( )
Avatar art thanks to Trev-Mun ( )
(08-27-2021, 07:36 AM)Flavor Wrote: I just wanted to add that one of the people I helped via email just wrote back and said that they tried multiple USB cables and that turned out to be their problem.  It's still odd to me that this is such a frequent occurrence.

So I went out and bought a data specific cable just to make sure it was that. But to no avail. Let me clarify, sound plays when I plug it in. It shows up in Zadig. However, on the Drive portion it says 

Driver [(NONE)] -> [WinUSB(v6. 1.7600.16385)]

I'm having trouble Installing drivers.

Update: Tried several other computers same results. I also bought two Flash Mastas and its the same for both of them.
Here are my specs:
OS: Windows 10 Pro v 20H2 (OS Build 19042.1165)
Processor: Intel® Core™ i7-6700HQ CPU @ 2.60GHz 2.59 GHz
System type: 64-bit operating system, x64-based processor

Update #2:
So I went ahead and read this thread and saw that people just hit the install button. I did that and it installed WinUSB(v6. 1.7600.16385) Im assuming that is what is suppose to do? Anyways I was able to install it successfully. I dont know if this is correct or not let me know.

Ok I figured out what my problem was. I miss understood the information that was being presented to me by Zadig because in the video tutorial I thought that I needed to see something under the driver section in order for Zadig to recognize the device but that is not the case at all. So, for anyone who needs a little guide I went ahead and wrote this up because I feel someone else may reason the same way I did and get confused. 

How to Properly Prepare your Flash Masta Wonderswan:

Step 1: Find a Micro USB DATA TRANSFER CABLE to USB 2.0/3.0 to make sure that data can be written or transferred from PC to Flash Masta Wonderswan and vise versa.

Step 2: Plug the Micro USB side into your Flash Masta Wonderswan Cart (located on top right if cart is facing you) and the other end into your PC USB port.

Step 3: If you have not already please visit and download    the required files starting from the top and working your way down.
           (Because I am working on a windows PC I will be downloading Zadig)

Step 4: When you click on Zadig it will send you here  scroll down to the downloads section and download the program (as of this writing the latest version is 2.5)

Step 5: Once the download process is complete locate the Zadig.exe file and double click to open it. 

Step 6: Now this is the part I got confused. When Zadig is running if it does not recognize your Wonderswan Flash Masta try a few things
        6a. Connecting to another USB port
        6b. Try going under options in Zadig and selecting [Show all Devices] and selecting it from the drop down menu.
        6c. Flavor also wrote about other possible solution in this thread if the top two solutions did not work

Note: This shouldn't be a problem anymore and it was not for me, like I said I just misunderstood the information presented. 

Step 7. Once Zadig recognizes your Wonderswan Flash Masta you will see the following information populated.

      WS Flash Masta USB
Driver [NONE] (green arrow) > [WinUSB (v6.1.7600.16385)]
USB ID [ 20A0] [4252]           
                                     [Install Driver]

When I saw this information I thought that the Wonderswan Flash Masta was not being recognized because in the video tutorial under the Drive section it shows [usbser (v1.0.0.0) and I thought that what was going to be written to the Wonderswan Flash Masta but its actually the opposite. That information is what IS on the Wonderswan Flash Masta currently and WinUSB (v6.1.7600.16385) is what will be written to it. SO the way to read this information is as followed. 
        Congratulations! your Wonderswan Flash Masta IS being recognized by Zadig and all you have to do is hit the [Install Driver] button and watch it go

Step 8. You will be greeted with a success popup window and your good to go and follow the rest of the tutorial video located here. 

If someone needs me to write up the next few steps let me know!

Forum Jump:

Users browsing this thread: 1 Guest(s)